Error actualizando con apt, Debian 9

Actualizando Debian 9, Stretch, de mi repo, me da este error y buscando en internet veo que es común para muchos usuarios…

[email protected]:~# apt update
Get:1 http://repo.dominio.cu/debian/stretch stretch InRelease [198 kB]
Reading package lists... Done
E: Release file for http://repo.dominio.cu/debian/stretch/dists/stretch/InRelease is expired (invalid since 1d 12h 44min 58s). Updates for this repository will not be applied.

Entonces, como resolvemos esta situación? Fácil…

Se recomienda ejecutar siempre:

[email protected]:~# apt -o Acquire::Check-Valid-Until=false update
Get:1 http://repo.dominio.cu/debian/stretch stretch InRelease [198 kB]
Ign:2 http://repo.dominio.cu/debian/stretch stretch/main amd64 Packages
Ign:3 http://repo.dominio.cu/debian/stretch stretch/main Translation-en
Ign:4 http://repo.dominio.cu/debian/stretch stretch/contrib amd64 Packages
Ign:5 http://repo.dominio.cu/debian/stretch stretch/contrib Translation-en
Ign:6 http://repo.dominio.cu/debian/stretch stretch/non-free amd64 Packages
Ign:7 http://repo.dominio.cu/debian/stretch stretch/non-free Translation-en
Get:2 http://repo.dominio.cu/debian/stretch stretch/main amd64 Packages [7094 kB]
Get:3 http://repo.dominio.cu/debian/stretch stretch/main Translation-en [5392 kB]
Get:4 http://repo.dominio.cu/debian/stretch stretch/contrib amd64 Packages [50.9 kB]
Get:5 http://repo.dominio.cu/debian/stretch stretch/contrib Translation-en [45.9 kB]
Get:6 http://repo.dominio.cu/debian/stretch stretch/non-free amd64 Packages [77.9 kB]
Get:7 http://repo.dominio.cu/debian/stretch stretch/non-free Translation-en [79.2 kB]
Fetched 12.9 MB in 3s (3649 kB/s) 
Reading package lists... Done
Building dependency tree... Done
All packages are up to date.

Y ya no saldrá ese problema.

O de lo contrario:

[email protected]:~# echo "Acquire::Check-Valid-Until "0";" > /etc/apt/apt.conf.d/10no--check-valid-until

Lo cual crea el archivo 10no–check-valid-until, dentro de /etc/apt/apt.conf.d/, y ya cumple dicha tarea.

Por lo demás queda actualizar y ponernos a trabajar una vez nos saltemos ese obstáculo.

Saludos y espero les sirva.

 

Sé el primero en comentar

Dejar una contestacion

Tu dirección de correo electrónico no será publicada.


*