Debian9, que rico!!! Pero…

Acabo de instalar Debian9, sin SystemD, por supuesto, y me encuentro que… No hay ifconfig, no hay netstat, no hay route entre otra serie de comandos que uso a diario. Que rico actualizamos Debian, pero pusimos una pequeña pero nada despreciable lista de comandos en “deprecated”. Joder!

Describo la experiencia.

Ok, lo primero fue instalar Debian 9 con el ISO netinstall y quitarle SYSTEMD, a continuación fue configurar la red, el resolv.conf para los settings del DNS, así como configurar mis interfaces de red para que se llamaran normalmente eth0, wlan0[joDT SystemD], etc.

Con todo esto configurado, bueno, todos sabemos:

apt update
apt upgrade
apt dist-upgrade

Entonces:

apt install plasma-desktop konsole dolphin synaptic kmix

Y con ese soporte mínimo a meterle manos al asunto. Reincia y listo.

Reinicia el sistema, muy lindo, tienes plasma-desktop 5.8.6 pero no carga nada? y KDM? Bien, deprecated también, WTF!?

Ok, toma ya:

apt install sddm
/etc/init.d/sddm restart

Y listo, gráficos, que rico…

Ahora bien, buscando en media internet, encuentro que netstat, ifconfig, route estan deprecated, ok, pero en un foro de RedHat recomiendan usar el paquete net-tools[ya no se instala por defecto], ante cualquier problema, Ok, dejame ver Debian 9 que tienes para mi:

Por supuesto, escribo este post después de haberlo instalado… Instala y dale taller. Bueno, net-tools trae netstat, route e ifconfig entre otros comandos. Listo, me salvé.

En fin, para no hacer mucho recuento, script[install_KDE.sh] con instalador automatico de todo lo necesario:

#!/bin/bash

apt install net-tools openjdk-8-jre dnsutils gpm ntfs-3g gparted phonon-backend-gstreamer \
 kde-baseapps-bin desktop-base plasma-desktop kde-config-touchpad lxappearance gpicview \
 ksnapshot kcolorchooser okular kmix konsole wpasupplicant wireless-tools dolphin \
 docky medit mc synaptic qtcurve python-setuptools python-mysqldb python-sqlite tar gzip \
 bzip2 zoo nomarch xz-utils lzma file cpio cabextract git p7zip-full conky-all intltool \
 hddtemp lsb-release lm-sensors mpv ark build-essential gstreamer1.0-nice \
 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly \
 gstreamer1.0-pulseaudio firmware-realtek

Ya iré viendo por el camino que mas necesitaré, pero por ahora es todo lo que medianamente necesito…

Al final todo quedó mas o menos así:

Debo pasarle la manos a la config de conky, me acabo de dar cuenta…

Un saludo y por el momento me despido. Ojalá les sirva…

2 Comments

Dejar una contestacion

Tu dirección de correo electrónico no será publicada.


*